QURL Application Solutions http://www.qurl.nl Quality and Reliability Wed, 06 May 2015 06:50:57 +0000 en-US hourly 1 Dynamic Widgets with qTranslate-X http://www.qurl.nl/2015/05/dynamic-widgets-with-qtranslate-x/ http://www.qurl.nl/2015/05/dynamic-widgets-with-qtranslate-x/#comments Wed, 06 May 2015 06:50:57 +0000 http://www.qurl.nl/?p=1108 Dynamic Widgets has had support for the now abandoned plugin qTranslate for a long time. Some time ago, qTranslate has been adapted by a few other folks and renamed to qTranslate-X. Dynamic Widgets has added support for qTranslate-X starting with version 1.5.10.

Unfortunately due to WordPress policies, the authors of qTranslate-X had to change some code. This resulted in a new incompatibility between qTranslate-X and Dynamic Widgets. For compatibility you can switch on a setting in qTranslate-X that makes Dynamic Widgets work again happily with qTranslate-X.

I quote one the authors of qTranslate-X in the WordPress Forum topic:
There is an option in qTranslate-X, “Compatibility Functions”, which enables back a list of functions with qtrans_ prefix: https://qtranslatexteam.wordpress.com/faq/#CompatibilityFunctions

Of course, Dynamic Widgets will be changed so this setting will not be necessary anymore in a new version.

]]>
http://www.qurl.nl/2015/05/dynamic-widgets-with-qtranslate-x/feed/ 0
Dynamic Widgets 1.5.10 http://www.qurl.nl/2015/05/dynamic-widgets-1-5-10/ http://www.qurl.nl/2015/05/dynamic-widgets-1-5-10/#comments Tue, 05 May 2015 11:51:24 +0000 http://www.qurl.nl/?p=1102 After a long time I could finally find some time to release a new version of Dynamic Widgets. Just a few things have been added to it. Not much this time. Below the changelog:

  • Added Japanese language file (locale: ja) – Arigato chacomv!
  • Added security preventing calling scripts creatively
  • Added detection of QTranslate-X

 

]]>
http://www.qurl.nl/2015/05/dynamic-widgets-1-5-10/feed/ 0
Dynamic Widgets 1.5.9 http://www.qurl.nl/2014/07/dynamic-widgets-1-5-9/ http://www.qurl.nl/2014/07/dynamic-widgets-1-5-9/#comments Wed, 16 Jul 2014 13:01:07 +0000 http://www.qurl.nl/?p=1037 Much earlier then anticipated I’ve released version 1.5.9 of Dynamic Widgets. A small but quite annoying bug made me decide to release this version. Also I’ve been able to add a new feature to it which was requested quite a few times. Below the changelog:

  • Added support for IP range
  • Bugfix for URL and Pages module does not show the green checkmark and not showing the settings made
  • Bugfix for Single Post Catregory is saved wrong
  • Bugfix for Strict warning notice in author_module.php at line 42

New feature requests are always taken into consideration. But it happens quite a few times I get requests I’m not certain there would be an audience for it. For that kind of requests I will create a poll and see the response on it. Based on the outcome of the poll I’ll take the request in consideration again. Currently there is poll running about a feature request: Filter based on coming from specific URL.

]]>
http://www.qurl.nl/2014/07/dynamic-widgets-1-5-9/feed/ 8
Poll: Filter based on coming from specific URL http://www.qurl.nl/2014/06/poll-filter-based-on-coming-from-specific-url/ http://www.qurl.nl/2014/06/poll-filter-based-on-coming-from-specific-url/#comments Wed, 25 Jun 2014 17:36:48 +0000 http://www.qurl.nl/?p=1014 Today someone asked me at the WordPress Forum if it would be possible to create a module in Dynamic Widgets that adds a filter based on coming from specific URL within the website. I answered that I like the idea, but I’m not so sure it would be used very much. To see how other users think about it, I created a poll.

So, what do you think?

Note: There is a poll embedded within this post, please visit the site to participate in this post's poll. ]]>
http://www.qurl.nl/2014/06/poll-filter-based-on-coming-from-specific-url/feed/ 3
Dynamic Widgets 1.5.8 http://www.qurl.nl/2014/06/dynamic-widgets-1-5-8/ http://www.qurl.nl/2014/06/dynamic-widgets-1-5-8/#comments Mon, 23 Jun 2014 15:21:20 +0000 http://www.qurl.nl/?p=1006 I’ve just released version 1.5.8 of Dynamic Widgets. I know, the time between releases is getting longer and longer. I have actually very good reasons for that, but unfortunately I can’t tell much about that already. I’m working on a very big project which hopefully is going public somewhere this year. It’s specific for the Dutch market, but has capabilities to roll out to other countries also.

Anyway, this is the changelog:

  • Renamed Mobile Device to Device for more expansion.
  • Removed the version number from the HTML comment.
  • Fixed a few strict warnings.
  • Fixed a few vulnerabilities discovered by Leon Juranic.

WARNING: When you upgrade manually, remove the dynamic-widgets directory first!

UPDATE: A small but can be annoying bug has been found. The URL and Pages module does not show your settings. The settings are working until you save new settings without reproducing the settings for URL and Page. A fix has already been released in the development version.

UPDATE 2: Apparently something went wrong with my test routines. Another small bug was found in the Single Post Category. Also this has been fixed in the development version.

]]>
http://www.qurl.nl/2014/06/dynamic-widgets-1-5-8/feed/ 10
Dynamic Widgets 1.5.7 http://www.qurl.nl/2014/02/dynamic-widgets-1-5-7/ http://www.qurl.nl/2014/02/dynamic-widgets-1-5-7/#comments Mon, 24 Feb 2014 20:55:06 +0000 http://www.qurl.nl/?p=977 Dynamic Widgets 1.5.7 is here! After many pleas from users finally with mobile device detection support. Further, I’ve integrated a new language (Serbo-Croatian) and fixed a few bugs.

You can download the new version from the WordPress Plugin Directory or wait for the announcement in your WordPress dashboard. When you upgrade manually, do not forget to perform a deactivate – activate cycle of the plugin.

]]>
http://www.qurl.nl/2014/02/dynamic-widgets-1-5-7/feed/ 13
Dynamic Widgets 1.5.6 http://www.qurl.nl/2013/10/dynamic-widgets-1-5-5/ http://www.qurl.nl/2013/10/dynamic-widgets-1-5-5/#comments Fri, 11 Oct 2013 17:51:48 +0000 http://www.qurl.nl/?p=940 I’m pleased to announce that the next update of Dynamic Widgets has just become avaialble. Version 1.5.5 1.5.6 has the following features added, bugs fixed and changes:

  • Added WordPress filter ‘dynwid_urlprefix’ in case Dynamic Widgets detects the URL wrong.
  • Added WordPress filter ‘dynwid_taxonomies’ to be able to remove taxonomies from the admin view.
  • Added WordPress filter ‘dynwid_admin_modules’ to be able to remove modules from the admin view by request of Rick Anderson from Build Your Own Business Website who made a financial contribution to make this possible.
  • Added Toggle all sections button for visually impaired users.
  • Bugfix for Notice: Trying to get property of non-object in post-template.php on line 1275.
  • Bugfix for not using a full PHP opening tag in dynwid_admin_overview.php.
  • Bugfix for exception rules in single post types sometimes not followed.
  • Bugfix for Warning: Declaration of DW_CustomPost::registerOption() should be compatible with DWModule::registerOption($dwoption)
  • Bugfix for WPML category fails to follow the rules with the help and financial support by Advancis.
  • Changed the taxonomy terms tree to use ‘lazy loading’ by request of Rick Anderson from Build Your Own Business Website who made a financial contribution to make this possible.
  • Moved minimum PHP version up to 5.2.7 because of a PHP bug in lower versions not exposing all class properties while in the right scope. Thanks S├ębastien for finding out!

UPDATE: The people who downloaded 1.5.5, please install 1.5.6. Due to a wrong copy command the wrong files were included in the 1.5.5 release.

 

]]>
http://www.qurl.nl/2013/10/dynamic-widgets-1-5-5/feed/ 23
WordPress 3.6 / 3.6.1 with Dynamic Widgets http://www.qurl.nl/2013/09/wordpress-3-6-3-6-1-with-dynamic-widgets/ http://www.qurl.nl/2013/09/wordpress-3-6-3-6-1-with-dynamic-widgets/#comments Tue, 17 Sep 2013 14:39:34 +0000 http://www.qurl.nl/?p=933 The last time I see a lot of support requests coming in claiming Dynamic Widgets would not work on WordPress 3.6 or 3.6.1. The tests I have done with serveral themes using the mentioned versions did not gave any issues. When you experience problems with Dynamic Widgets and WordPress 3.6 or 3.6.1, please let me know in the comments. Please provide me with details about your problem and the theme you’re using and where I can find it. Please note that I can only look at themes which are free.

]]>
http://www.qurl.nl/2013/09/wordpress-3-6-3-6-1-with-dynamic-widgets/feed/ 2
End of life Tweet Lovers http://www.qurl.nl/2013/04/end-of-life-tweet-lovers/ http://www.qurl.nl/2013/04/end-of-life-tweet-lovers/#comments Mon, 22 Apr 2013 13:44:57 +0000 http://www.qurl.nl/?p=908 Twitter has announced it will stop using version 1.0 of the Twitter API on May 7, 2013. This API is used by Tweet Lovers. I have decided not to update Tweet Lovers anymore. This means Tweet Lovers will not work anymore from May 7, 2013.

For the ones who are using this small plugin, I apologize. Tweet Lovers has never made it to such a success as my other plugin Dynamic Widgets is.

]]>
http://www.qurl.nl/2013/04/end-of-life-tweet-lovers/feed/ 0
Dynamic Widgets 1.5.4 http://www.qurl.nl/2012/12/dynamic-widgets-1-5-4/ http://www.qurl.nl/2012/12/dynamic-widgets-1-5-4/#comments Sat, 15 Dec 2012 16:35:27 +0000 http://www.qurl.nl/?p=881 I’ve just released version 1.5.4 of Dynamic Widgets. Just a small update release this time. Mostly because of a small issue given by wrong configured webservers spitting out a notice when upgrading to WordPress 3.5.

The following has changed:

  • Added Danish language file (locale: da_DK) – Tak Morten!
  • Bugfix for WPML postID finder reports 0 when WPML language is unknown.
  • Bugfix for Single Post Rules are lost when autosave of single post is made
  • Bugfix for Warning: Missing argument 2 for wpdb::prepare().
  • Upgraded the Pods module to support Pods version 2. – Thanks Scott for the help!
  • Widend the widget_id space because of looooong widget names.
  • Moved to WordPress time in stead of server time for the date/time based modules.

Witin three days time 11 people voted “Broken” on the combination WordPress 3.5 and Dynamic Widgets 1.5.3. I’m wondering how long it will take when those 11 people have voted again for the combination WordPress 3.5 and Dynamic Widgets 1.5.4.

]]>
http://www.qurl.nl/2012/12/dynamic-widgets-1-5-4/feed/ 105